WatchOS 4.3.1 beta warns that watchOS 1 apps won't work on future versions

If you're using an old Apple Watch app that hasn't been updated in a while, you might run into some problems when watchOS 5 lands (likely sometime this fall). The latest beta of watchOS 4.3.1, which is sort of the watchOS equivalent of iOS 11.4, warns you when you try to launch an out-of-date app.

"This app will not work with future versions of watchOS. The developer of this app needs to update it to improve its compatibility."

That's the warning that pops up on your Apple Watch when you...

What feeling does this article give you?
Joy
Disgust
Fear
Anger
Sadness

#hashtags to follow:

Apple Watch [+]   

More #news: